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Preface
Why would I write a new book about building Web sites using an obsolete program like
FrontPage 2003? Well, in my opinion, it works and it works well. Sure, it does not meet
the latest XHTML requirements. But, it works, and it builds a fairly clean HTML site that
works on all browsers. I seriously doubt the doomsayers that tell us browsers in the future
will not support the old code. Come on, they still support depreciated code that has
not been recommended for years! I believe we are safe for years to come if not for the
life of the Internet as we know it. I am using Microsoft Word 2007 to write this and the
spell checker does not even like XHTML. Go figure.
There are thousands of Web sites built using FrontPage and I assume you may be one of
those. Or perhaps you are new to Web site creation and want to get started. An easy
way to do that is to get plugged into one of those host sites that does it all for you. Not
much fun in that and not much flexibility.
I am not going to teach you how to use FrontPage from the ground up. I am also not
teaching you HTML. What I will do is show you step-by-step, with pictures included, how
to build a simple site with multiple pages that is easily modified.
If you do not have FrontPage 2003, I suggest eBay or a Google search to locate a used
copy. If you have Office 2003 Professional, you already have it, as it was included in
that package. If you have an older version of FrontPage, most of what I teach will work,
but the screen shots will be unlike the ones you will be seeing.
Can this method work with the new Expression Web application? Yes and No. Some of
the tools available in FrontPage were not included in Expression Web. However, if you
have a site using pages built with FrontPage, Expression Web will allow you to use the
tools to maintain it. Strange! SharePoint Designer is a sister application to Expression
Web and it is very similar to Expression Web, but it does support some of the FrontPage
tools.
FrontPage supports CSS (Cascading Style Sheets) and DWT files (Dynamic Web
Templates), but does not require using them. Expression Web and SharePoint Designer
use STYLEs by default when you code in the WYSIWYG designer mode. They expect you
to be using CSS, but do not require them. The only way to create code in HTML without
STYLEs is to code in HTML at the code mode level.
Do not get me wrong. I support using style sheets and dynamic templates. You just
cannot build a simple Web page that way. So if you are new to HTML coding, I suggest
you try my simple approach first. Get some sites up and running, then take the time to
dabble in CSS and DWTs.
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Building a Simple Web Site
By Dick Evans
I use HTML when I build Web sites. Although I understand that CSS is the current “way to
go” and that the old methods are frowned upon, they all still work in any browser.
Although I use FrontPage 2003 to develop Web sites, I still resort to the Code window to
tweak the HTML.
FrontPage sites do need FrontPage extensions loaded at the host site, but this is not an
issue as most hosting sites make the available. If you do not call for any of the
extensions in your code, the host site does not need to have them installed.
What follows is one method I use. It makes building a multipage site quick and easy. It
assumes you are using FrontPage 2003 as your development application. This simple
method gives you one place to maintain the banner for all pages and one place to
maintain the footer. A link bar can be placed in either or both the banner and the
footer pages.
I start a new site building a template page containing the formatting and color scheme
I intend for all pages in the site. Next I create a standard banner and link bar to be
included on all pages. Using this approach, I only have to maintain one page to
update the banner or links for all pages.
After creating the template page, I use it for all new pages. To build a new page, I
open the template page created below and save it with a new name. Then I add the
body code to the new page. Next I open the page where the link bar resides and add
a link to open the new page.
The following instructions assume you know how to use FrontPage and have some basic
HTML knowledge. The first section builds the template page, which never displays on
the site. The template is only needed to create new pages. Following that is a section
on creating the index page and adding the link bar. Next an about page is added to
the site and to the link bar. Additional pages follow the same method.
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Building the Template
1. Open FrontPage 2003

2. File > New > One page Web site

3. Double-click to open the index.htm page for editing

4. Using the tool on the standard toolbar, insert a 1 cell table
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5. Right-click in the table, and then select Table properties

6. Make the following changes:
a. Make the table 700 pixels wide
b. Horizontal center
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c.
d.
e.
f.

0 cell padding
10 cell spacing
0 border
Background white (or a color of your choice)

7. Right click on the page and select Page properties

a. Use a title with ownership name and brief description of the purpose of the
page.

b. Format the page background a contrasting color to the table background
color
c. Set the hyperlink colors
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8. File > Save as template.htm

9. If necessary, open the template.htm page

10. File > Save as banner.htm

11. Whatever is on this page becomes the banner at the top of the page for all pages
a. This is where a picture/logo may appear
b. This is where the name of the Web site may appear
c. This is where a top link bar may appear
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12. Open the template.htm page
13. File > Save as footer.htm

14. Whatever is on this page becomes the footer and displays at the bottom of all
pages
a. This is where the link bar may be created for all pages
b. This is where the © line may be displayed
c. This is where the name and contact material may go
d. This is where a link to the webmaster may appear

15. Open the template page
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a. Above the table include the banner
i. Insert > Web Component

b. Using the same method, below the table include the footer

c. Save the page as the final template page
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When viewed in a browser, the page is always centered and never changes size if the
screen resolution is less or more than 700 pixels wide. The page background makes a
nice contrast to the page itself.
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Creating the Home Page
1. Open the template page.

2. Ctrl+A to select all the code, then Ctrl+C to copy it to the clipboard

3. Open the index.htm page
4. Switch to the code window
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5. Ctrl+A to select all the code, and then press Delete to remove it.

6. Ctrl+V to copy the code saved to the clipboard
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7. Switch to the Design view

8. Add the body text and images desired

9. Modify the Page Properties to fit the new page
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10. Save the page and try it out in a browser. I suggest all images be placed in the
image folder. Leave the root directory (folder) for the html files.
Note: to locate the “geeking text” used in the above sample and lots of other HTML
goodies, open www.rwevans.com and click the HTML Template link located in the left
pane.
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Adding a Link Bar

1. Open the footer page (or the banner if you would rather have the links at the top of
the page).
2. Insert a horizontal line above the © line, if desired. Then add a line to contain the
links. Type Home followed by a space and a vertical line (the piping character
located above the Enter key—the shift backsplash key). This line is used to separate
the links. Some like to use a dot, others place the links in square brackets, and some
use a dash. I like the |.

3. Select just the word(s) to be linked and not the space or the |.

4. Ctrl+K to open the link dialog box. Select the page the link should open.
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5. Click Screen Tip and type a description of the result of clicking the link.

6. Save the page. Then open the index page and try it out the link in the browser.
Notice that the index (home) page shows the link at the bottom of the page.
Whenever the footer is changed, the results will appear in all pages. The same is true
for the banner page.
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Adding a New Page

1. Open the template page.

2. Save it AS the name of the new page. This is a very important step as you do not
want to modify the template itself.
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3. Add the details for the body.

4. Change the Page Properties
5. Save the page.
6. Open the footer page

7. Add the link to the new page
8. Save the footer page. Then open the new page and try it out the link in the browser.
Notice that all pages show the links at the bottom of the page and all links work.
Whenever the footer is changed, the results will appear in all pages. The same is true
for the banner page.
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That is it. Using the template page makes it easy to develop multi-page Web sites. The
included banner and footer pages make controlling the look and feel and linking at a
central point rather than having to change every link bar on every page in the site
each time a new page is added or removed. The included pages do not require the
use of FrontPage extensions, so you can take what was created and FTP it to any host
site.
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Rounded Corners

Perhaps you do not like the square corner approach. Well, adding rounded corners is
easy. The banner page has to be modified. Right now it looks like the following:

The table is one cell with cell spacing set to 10. The cell spacing is what creates that
border around the cell.

The above is what we want it to look like. It is no longer a single cell table, but a 2x3
tables set as follows:
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The top left and top right corners will each have a graphic with a rounded corner.

1. Set the background color for the table is set to white and the top corner of each
rounded image is set to the page background color. Merge the center cells of the
two rows together.
2. Set the top left cell to align left and the top right cell to align right.
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3. Set the width of each top corner cell is 20 pixels.
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Creating Rounded Corner Images
Next we need to create a corner graphic. There are many great graphics applications
out there, but we are using the Paint program that comes with Windows.

4. Open the Microsoft Paint program:
Windows+R > type MSPAINT > press Enter
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5. Using the Fill tool (paint can) color the background black.

6. Click the Ellipse button, then hold the shift key down and drag to create a perfect
white circle

7. Use the Select tool to select the top left quarter of the circle.
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8. Drag it to the top left.

9. View > Zoom > Large size
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10. Move the rounded white line so there is no black on the top or left and fill the area
to the right of it all white.

11. View > Zoom > Normal Size
12. Grabbing the blue dot in the lower right corner, drag up and to the left to only show
the rounded line, and then return the large size.
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13. Move the bottom up so there is one cell of white showing under the black on the
left, and the right bar to the left so there is one white showing before the top black.
Then return to the normal size.

14. File > Save As > top_left.jpg
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Inserting the Rounded Corners into the Banner Page

15. Click in the top left cell, and then Insert Picture > From File and locate the
top_left.jpg image saved above. Save the page. Save the image changing the
format to .png

16. Click in the top right cell, and then Insert Picture > From File and locate the
top_left.jpg image saved above. Save the page changing the name of the image
to top_right and the format as .png.
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17. Right-click on each of the cells with a purple background, and set the cell
background color to white.

18. On the picture tool bar, click Flip Horizontal

19. Click on the top_left image to select it, and then click the transparency tool. Point to
the top portion of the image and click so the table background bleeds though. Do
the same for the top_right.

Note: if the bottom or a side of the rounded corners have a purple line, then doubleclick the image and change its width upward by a few pixels. Do the same for both
right and left images.
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20. Try out the other pages and see the new banner.
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I hope this simple approach to building and maintaining a Web site works as well for
you as it has for me. Please let me know what you think about it and pass along any
ideas you have to add to or even improve it.
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Building a Simple Web Site
By Dick Evans
I use HTML when I build Web sites. Although I understand that
CSS is the current “way to go” and that the old methods are
frowned upon, they all still work in any browser. Although I use
FrontPage 2003 to develop Web sites, I still resort to the Code
window to tweak the HTML.
What about the new Expression Web, you say? It is not
FrontPage. If you have never developed Web sites or have been
using Dreamweaver, this may be the way for you to go. It makes
extensive use of CSS and DWT. You can use these in FrontPage,
but your sites do not revolve around these methods.
Web Development was one of the courses I taught while
teaching at Rhode Island college from 1986-2009. We used HTML
and FrontPage and then in the last few semesters, Expression
Web.
I continue to build and maintain a number of Web sites mostly
for non-profit organizations as well my personal sites and our
ministry site at www.TheEvans.org.
This book describes the method I use to build simple Web sites. I
use FrontPage 2003, but other applications could be used. I
believe you will find this instructional book easy to follow and a
worthwhile addition to your tool bag.

